Fleasystems forum
Problems installing F32C toolchain - Printable Version

+- Fleasystems forum (http://www.fleasystems.com/forums)
+-- Forum: FleaFPGA Uno Project Forum (/forumdisplay.php?fid=22)
+--- Forum: Startup Support Topics (/forumdisplay.php?fid=23)
+--- Thread: Problems installing F32C toolchain (/showthread.php?tid=61)

Pages: 1 2

Problems installing F32C toolchain - Myndale - 11-30-2015 01:47 PM

I've run into a problem installing the tool chain for F32C on Flea UNO. I've done a fresh install of both 1.6.6 and 1.6.4 (currently left it on the latter) and I followed the instructions over at their site, but if I simply add the line "Serial.begin(9600);" anywhere in the code I get an error:

MyApp.ino: In function 'void setup()':
MyApp:3: error: 'Serial' was not declared in this scope
'Serial' was not declared in this scope

The f32c serialprint example isn't compiling either (the other architectures seem to compile fine). I've tried both the automatic and manual installs, same problem occurs on each.

Any ideas what the problem might be? Or should I ask the f32c guys about this one?

Ok, I've looked into this a bit deeper now and it looks like a genuine tool chain issue, the Serial externs have been commented out of variant.h:

#ifdef __cplusplus
#include "UARTClass.h"

//extern UARTClass<IO_SIO_BYTE, IO_SIO_STATUS, IO_SIO_BAUD> Serial;            // FTDI USB UART
//extern UARTClass<IO_SIO_BYTE_1, IO_SIO_STATUS_1, IO_SIO_BAUD_1> Serial1;    // ESP-8266 UART

Commenting them back in results in a compile time error due to the fact that UARTClass (on my machine at least) is not a templated class. Instancing it with the non-templated version however works fine, so at least I now have debug output. Smile

Val, I'm guessing you had to template this in order to add ESP8266 support, have I missed an install step or have you simply not had a chance yet to release your changes?

RE: Problems installing F32C toolchain - Fleasystems - 11-30-2015 09:18 PM


Hello and thanks for your question.

First off, by 'their site' I assume you mean http://www.nxlab.fer.hr/fpgarduino/ ?

If that is the case, I would suggest that you instead use the specific instructions provided to you in my shipping confirmation email sent to you on November 25th.

Now, I suggest this because FleaFPGA Uno hardware has not yet been fully integrated into their F32c IDE plugin (work in progress currently), so currently the only workable solution is the one provided you via email.

Hope this helps,

PS: Also, I would greatly appreciate it if you could reply to my email question around what Windows version you are running. Thanks!

RE: Problems installing F32C toolchain - Myndale - 12-01-2015 07:50 AM

Thanks for the response Valentin, I'm actually seeing this problem in both cases i.e. regardless of whether I follow the instructions in your mail or the ones on the fpgarduino site. I just did another complete re-install of Arduino from scratch, following the instructions in your mail verbatim, and it again failed on step 10 (compiling/uploading f32c_consoletest) due to the "Serial.begin()" statement.

Will mail you offline regarding the other issue (I'm on Win10).

Solved it, turned out to be typical Arduino IDE flakiness. Under the Tools menu it was saying "Board: FleaFPGA-Uno", but when I expanded that menu to see the entire list of boards the FleaFPGA-Uno option didn't actually have a check mark next to it. As soon as I re-selected it everything started compiling fine. Seems that when I downgraded from 1.6.6 to 1.6.4 it lost track of which board I'd selected but still cached the name in the main Tools menu. Weird.

RE: Problems installing F32C toolchain - Fleasystems - 12-01-2015 09:34 AM


Thanks for your update. Glad to hear your problem was solved. Smile

For future reference, I could ask users to also visually check if FleaFPGA Uno board is selected in the boards manager, prior to checking for correct SRAM size, Pin mappings and upload COM port # etc.


RE: Problems installing F32C toolchain - Myndale - 12-01-2015 05:53 PM

On a somewhat-related note the current GitHub build of f32c for Lattice/FleaFPGA_Uno_bram_sram8 appears to be broken:

ERROR - C:/Dev/f32c/rtl/soc/vgahdmi/VGA_textmode_bram.vhd(73,40-73,56) (VHDL-1241) font8_block_type is not declared
ERROR - C:/Dev/f32c/rtl/soc/vgahdmi/VGA_textmode_bram.vhd(73,66-73,83) (VHDL-1241) font16_block_type is not declared
ERROR - C:/Dev/f32c/rtl/soc/vgahdmi/VGA_textmode_bram.vhd(105,21-105,26) (VHDL-1241) font8 is not declared
ERROR - C:/Dev/f32c/rtl/soc/vgahdmi/VGA_textmode_bram.vhd(107,21-107,27) (VHDL-1241) font16 is not declared
ERROR - C:/Dev/f32c/rtl/soc/vgahdmi/VGA_textmode_bram.vhd(114,52-114,65) (VHDL-1241) font8x8_block is not declared

I'm running Lattice Windows 64-bit v3. Do you know if there's a stable commit I can roll back to? Or should I open an issue for it?

RE: Problems installing F32C toolchain - Xark - 12-01-2015 06:55 PM

Hello Myndale,

I have been working with the f32c folks on various things (including FleaFPGA-Uno support). It is difficult to keep all the FPGA boards up to date while adding features to the core (currently working on VGA textmode fine scrolling...).

The FleaFPGA-Uno files were updated fairly recently (and I think pushed to Arduino "board manager"), but then after that the fonts were renamed (and perhaps some other changes) that likely broke FleaFPGA-Uno design.

I will look to get it fixed in the next day or two and pushed back to f32c GitHub (I also have a mirror at https://github.com/XarkLabs).

Sorry for your troubles, but hang in there and we will get you a good build soon.


RE: Problems installing F32C toolchain - Myndale - 12-01-2015 08:01 PM

All good Xark, thanks for the update. Such are the joys of being an early adopter! Smile

Been having a lot of fun so far with both FleaFPGA-Uno and F32C, very smooth sailing overall considering all the work that's currently being done.

RE: Problems installing F32C toolchain - Xark - 12-02-2015 07:31 PM

Excellent, I am very glad to hear that. :-)

I believe f32c GitHub (as well as XarkLabs fork) has been updated with f32c for FleaFPGA-Uno (and the "FleaFPGA_Uno_revE.ldf" Diamond project should build for you without problems). Also some matching VGA examples in f32c/arduino project (libraries/f32c_VGATextConsole). However, the "SRAM bitmap" overlay and 2nd UART (for optional ESP-8266) are disabled currently. I am currently working to fix these remaining issues (almost got bitmap working correctly, then UART will be a f32c core software fix - port HW is fine).

This current version also supports Arduino AVR style "INPUT_PULLUP" pull-up resistors on inputs (a special FleaFPGA-Uno feature) and 328P style low-level C/C++ GPIO access (PORTx, DDRx, PINx direct access vs digitalRead/digitalWrite). Both of these can help porting other Arduino libraries to FleaFPGA-Uno/f32c.

I hope to have a fully working version soon (but 2nd serial UART may take a couple more days).


P.S. I am currently watching a "Boulderdash" clone animating on the FleaFPGA-Uno (under f32c). A nice test app for re-definable character graphics. :-) https://github.com/f32c/arduino/tree/master/libraries/f32c_VGATextConsole/examples/boulder

RE: Problems installing F32C toolchain - Xark - 12-03-2015 07:24 PM

Hello again,

Okay, in my https://github.com/XarkLabs the latest and greatest FleaFPGA-Uno f32c and arduino run-time modifications. Bitmap overlay is fully operational (with test program). Also I have re-added the second UART for ESP-8266 access (in case you have that option).

I think everything should be buildable the the f32c_VGATextConsole library has some example projects (E.g., f32c_TwoColorBitMap). I think "boulder" should run fine too, but you need to change an "80" to "82" because of different screen width (atm, due to fine scrolling enabled). I think actual scrolling and PS/2 control for the game are being worked on.

Let me know if you have any trouble (or requests for FleaFPGA-Uno f32c features or changes).


P.S. I suspect this will be merged into main f32c GitHub soon (pull requests sent).

RE: Problems installing F32C toolchain - Myndale - 12-03-2015 10:06 PM

Heya Xark,

I just did a git clone of https://github.com/XarkLabs/f32c.git. FleaFPGA_Uno_revE.ldf still doesn't seem to be building but project.ldf does. Very late here so will have to test the latter on the hardware in the morning. Thanks again for all the work you're putting into this!